<!DOCTYPE html>
<html lang="en" prefix="article: http://ogp.me/ns/article# dc: http://purl.org/dc/terms/# og: http://ogp.me/ns# twitter: https://dev.twitter.com/cards/markup#" vocab="http://schema.org/">
<head>
  <meta charset="UTF-8">
  <meta content="en" name="DC.language" property="dc:language og:locale">
  <meta content="Latest TP-Link updates resolve NTP data squandering firmware issue" name="DC.title" property="dc:title og:title twitter:title">
  <meta content="Latest TP-Link updates resolve NTP data squandering firmware issue" property="og:title">
  <meta content="Daniel Aleksandersen" name="DC.author" property="article:author dc:creator">
  <meta content="Daniel Aleksandersen" property="article:author">
  <meta content="Daniel Aleksandersen" name="author">
  <meta content="@Aeyoun" property="twitter:creator">
  <meta content="Ctrl blog" name="DC.publisher" property="dc:publisher og:site_name">
  <meta content="Ctrl blog" property="og:site_name">
  <meta content="Ctrl blog" name="publisher">
  <meta content="2017-12-24T01:23:48+00:00" name="DC.issued" property="article:published_time dc:issued">
  <meta content="2017-12-24T01:23:48+00:00" property="article:published_time">
  <meta content="2017-12-24T01:23:48+00:00" name="DC.created" property="dc:created">
  <meta content="TP-Link updates repeaters to rely on ICMP and no longer send excessive NTP/DNS requests every 5 seconds." name="DC.description" property="dc:description og:description twitter:description">
  <meta content="TP-Link updates repeaters to rely on ICMP and no longer send excessive NTP/DNS requests every 5 seconds." property="og:description">
  <meta content="TP-Link updates repeaters to rely on ICMP and no longer send excessive NTP/DNS requests every 5 seconds." name="description">
  <meta content="urn:uuid:c48ce01d-208e-4724-8113-c41550e9609c" name="DC.identifier" property="dc:identifier">
  <meta content="https://www.ctrl.blog/entry/ntplink-fixed" property="og:url">
  <meta content="@CtrlBlog" property="twitter:site">
  <meta content="summary" property="twitter:card">
  <meta content="article" property="og:type">
  <meta content="#66b4ab" name="theme-color">
  <meta content="#66b4ab" name="msapplication-TileColor">
  <meta content="https://www.ctrl.blog/assets/msapplication/tile_150x150.png" name="msapplication-TileImage">
  <meta content="width=device-width, initial-scale=1" name="viewport">
  <meta property="og:image" content="https://www.ctrl.blog/media/tplink-time-1072x603.jpeg">
  <meta property="og:image:width" content="1072">
  <meta property="og:image:height" content="603">
  <meta property="og:image" content="https://www.ctrl.blog/media/tplink-time-300x300.jpeg">
  <meta property="og:image:width" content="300">
  <meta property="og:image:height" content="300">
  <meta name="twitter:image" content="https://www.ctrl.blog/media/tplink-time-300x300.jpeg">
  <meta content="pd2qvz" name="flattr:id">
  <link href="/manifest.json" rel="manifest">
<title>Latest TP-Link updates resolve NTP data squandering firmware issue &#8211; Ctrl blog</title>
<link rel='stylesheet' id='css-0-css'  href='https://www.ctrl.blog/assets/cjs/f0440d99-1514330042.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='css-1-css'  href='https://www.ctrl.blog/assets/cjs/6a8b10ae-1511816289.min.css' type='text/css' media='all' />
<link rel='prev' title='Exploring Bitcoin vanity addresses' href='https://www.ctrl.blog/entry/bitcoin-vanity-address' />
<link rel='next' title='Top 10 most read articles of 2017' href='https://www.ctrl.blog/entry/2017-most-read' />
<meta name="generator" content="WordPress 4.9.1" />
<link rel="canonical" href="https://www.ctrl.blog/entry/ntplink-fixed" />
    <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
    <script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:'ca-pub-1835247814769107',enable_page_level_ads:1});</script>
  <link href="/favicon.ico" rel="icon" type="image/x-icon" sizes="16x16 24x24 32x32 64x64">
  <link href="/favicon.svg" rel="icon" type="image/svg+xml" sizes="any">
  <link href="/assets/img/icon-32.png" rel="icon" sizes="32x32">
  <link href="/assets/img/icon-48.png" rel="icon" sizes="48x48">
  <link href="/assets/img/icon-96.png" rel="icon" sizes="96x96">
  <link href="/assets/img/icon-192.png" rel="icon" sizes="192x192">
  <link href="/favicon-mask.svg" rel="mask-icon" type="image/svg+xml" sizes="any" color="#7Fc03a">
  <link href="/apple-touch-icon.png" rel="apple-touch-icon" sizes="180x180">
  <link href="https://www.ctrl.blog/feed" rel="alternate" title="Ctrl blog – Feed" type="application/atom+xml">
  <link href="https://www.ctrl.blog/?ical" rel="alternate" type="text/calendar">
  <link href="https://www.ctrl.blog/osd.xml" rel="search" title="Ctrl blog" type="application/opensearchdescription+xml">
  <script>
    document.createElement('article');document.createElement('aside');document.createElement('footer');
    document.createElement('header');document.createElement('nav');document.createElement('main');
    document.createElement('picture');document.createElement('section');
  </script>
</head>
<body typeof="WebPage">
    <meta property="lastReviewed" content="2017-12-24T01:23:48+00:00">
    <link property="url" href="https://www.ctrl.blog/entry/ntplink-fixed">
  <div id="page-container">

    <header id="page-header">
      <h1><a href="https://www.ctrl.blog/">
        <span class="page-header-ctrl">Ctrl</span> <span class="page-header-blog">blog</span>
      </a></h1>
      <nav>
        <ul>
          <li>
            <a href="/popular" title="Most read articles">Popular</a>          </li>
          <li>
            <a href="/sitemap" title="Browse topics and archives">Topics</a>
          </li>
          <li>
            <a href="/subscribe" title="Get updates from Ctrl blog">Subscribe</a>
          </li>
          <li>
            <a href="/tip-jar" title="Don’t forget to tip your writers!">Tip jar</a>
          </li>
          <li>
            <a href="/about" title="Learn about the blog and the author">About</a>
          </li>
          <li>
            <a href="/search" title="Site search">Search</a>
          </li>
        </ul>
      </nav>
    </header>

<aside class="adco adco-fv">
<small>Advertisement</small>
<ins class="adsbygoogle adu-fb adu-fh adu-fv adu-fvt" data-ad-client="ca-pub-1835247814769107" data-ad-format="auto" data-ad-slot="3279101440"></ins><script>(adsbygoogle=window.adsbygoogle||[]).push({})</script>
</aside>


      <main class="doc-container single-page">
        <article class="post-7190 post type-post status-publish format-standard has-post-thumbnail hentry category-entry tag-networking" id="article-7190" property="mainEntity" typeof="BlogPosting">
	        <header class="entry-header">
        <div class="post-thumbnail" property="image" typeof="ImageObject"><img width="704" src="https://www.ctrl.blog/media/tplink-time-704x396.jpeg" class="attachment-wide-0704 size-wide-0704 wp-post-image" alt="TP-Link logo embedded in a clockface" property="url" srcset="https://www.ctrl.blog/media/tplink-time-704x396.jpeg 704w, https://www.ctrl.blog/media/tplink-time-300x169.jpeg 300w, https://www.ctrl.blog/media/tplink-time-1024x576.jpeg 1024w, https://www.ctrl.blog/media/tplink-time-240x135.jpeg 240w, https://www.ctrl.blog/media/tplink-time-320x180.jpeg 320w, https://www.ctrl.blog/media/tplink-time-496x279.jpeg 496w, https://www.ctrl.blog/media/tplink-time-688x387.jpeg 688w, https://www.ctrl.blog/media/tplink-time-960x540.jpeg 960w, https://www.ctrl.blog/media/tplink-time-992x558.jpeg 992w, https://www.ctrl.blog/media/tplink-time-1072x603.jpeg 1072w, https://www.ctrl.blog/media/tplink-time-1376x774.jpeg 1376w, https://www.ctrl.blog/media/tplink-time-1408x792.jpeg 1408w" sizes="(max-width: 704px) 100vw, 704px" />        <meta property="width" content="704"> <meta property="height" content="396"></div><h2 class="entry-title p-name" property="headline name">Latest TP-Link updates resolve NTP data squandering firmware issue</h2>        <p class="dateline">
          Published: <time class="entry-date dt-published published updated" datetime="2017-12-24T01:23:48+00:00" content="2017-12-24T01:23:48+00:00" property="datePublished" title="Publication time">2017-12-24</time>      </p>
	</header>
		<div class="e-content entry-content" property="articleBody">

<p>The latest firmware update for TP-Link repeaters/range extenders saves their customers approximately 715 MB every month in unwanted internet traffic.</p>

<span id="more-7190"></span>

<p><time datetime="2017-11-24">A month ago today</time>, I wrote about <a href="https://www.ctrl.blog/entry/tplink-aggressive-ntp" title="“TP-Link repeater firmware squanders 715 MB/month”">a design flaw in the firmware of TP-Link WiFi repeaters</a> that caused these devices to waste roughly 715 MB of data per month each in meaningless NTP traffic. TP-Link has now released firmware updates for most of their still-supported models that include the following change log entry:</p>

<figure class="figfull quote">
<blockquote>
<p>“Improved Online detection method and reduced unnecessary data traffic.”</p>
</blockquote></figure>

<aside class="adco adu-in"><small>Advertisement</small><ins class="adsbygoogle adu-fb adu-fr" data-ad-client="ca-pub-1835247814769107" data-ad-format="rectangle" data-ad-slot="9890932244"></ins><script>(adsbygoogle=window.adsbygoogle||[]).push({})</script></aside>

<p>The update changes the online connectivity check in TP-Link’s products to no longer sending one NTP request and five DNS requests out on the public internet every five seconds. These excessive checks resulted in a data consumption of approximately 715 MB per month per device.</p>

<p>The new check consists of sending one ICMP ping request to the local network gateway/router every five seconds instead. This means TP-Link repeaters will remain fairly chatty devices on your local network, but they will no longer slowly eat up your monthly data cap with your internet service provider.</p>

<section>
<h4>Firmware update availability by model</h3>
<ul>
  <li>RE650 V1 (update available)</li>
  <li>RE500 V1 (no information – notably the <a href="https://www.ctrl.blog/entry/tplink-re650-vs-re500" title="“What is really the difference between TP-Link RE650 and RE500? Firmware limits.”">hardware is identical to RE650 V1</a>)</li>
  <li>RE450 V1 and V2 (update available)</li>
  <li>RE350 V1 (update available)</li>
  <li>RE305 V1 (update available)</li>
  <li>RE205 V1 (no update, but problem has been acknowledged)</li>
  <li>RE200 V2 (no update, but problem has been acknowledged)</li>
  <li>TL-WA855RE V2 and V3 (update available)</li>
  <li>TL-WA850RE V4 and V5 (update available)</li>
</ul>
</section>

<p>This update also <strong>removes the non-functioning check-for-update interface</strong> mechanism in TP-Link’s web administration interface. Rather than to fix the update check and introduce proper auto-update, TP-Link chose to removed people’s abilities to pretend to check-for-updates. I guess that is progress? Customers must manually check for and download the firmware update from their local TP-Link website.</p>

<p>Please note that the update downloads are <strong>only available in some countries</strong> through the local TP-Link website in each country. Firmware for your region may still be available from a neighboring country. The problem appears to be that TP-Link just has bad routines for pushing out updates to each of their country-specific websites.</p>

<p>I wrote about this issue extensively in “<a href="https://www.ctrl.blog/entry/tplink-firmware-outdated-downloads">TP-Link serves outdated or no firmware at all on 30% of its European website</a>”. For this specific firmware release, the issue also affects TP-Link’s websites in the United States for some models.</p>

<hr />

<p>While researching this article, I noticed that some TP-Link repeater models have received updates for the KRACK Attacks security vulnerabilities that were disclosed in <time datetime="2017-10">October 2017</time>. About half of the models mentioned above have yet to receive updates for KRACK Attacks. These security updates have also only been pushed out in some countries; but the firmware for some models may be outdated even in countries that have received updates for other models. Which countries receive which updates appears to be a matter of random chance.</p>

<footer>
<h4>Sources</h4>

<ul>
  <li><a href="http://www.tp-link.jp/news-details-17792.html" hreflang="ja" lang="ja">&lt;更新&gt;TP-Link製無線LAN中継器によるNTPサーバーへのアクセスに関して</a> (in Japanese), <time>2017-12-22</time>, News release, TP-Link Japan</li>
</ul>
</footer>	  </div>
	  <footer class="entry-footer metadata">
      <aside>
<p><a href="https://twitter.com/CtrlBlog" onclick="this.href='https://twitter.com/intent/follow?user_id=3229266455'" rel="noopener nofollow" style="background-color:#55acee;color:#fff;background-image:url('/assets/svg/twitter.svg')" target="_blank">Follow Ctrl Blog on Twitter!</a></p>
<p><a href="https://feedly.com/i/subscription/feed/https%3A%2F%2Fwww.ctrl.blog%2Ffeed" rel="noopener nofollow" style="background-color:#86bb4d;color:#fff;background-image:url('/assets/svg/feedly.svg')" target="_blank">Follow Ctrl Blog on Feedly!</a></p>
      </aside>
      <link href="https://www.ctrl.blog/entry/ntplink-fixed" property="url">
      <link href="https://www.ctrl.blog/entry/ntplink-fixed" property="mainEntityOfPage">
      <div property="publisher" typeof="Organization">
        <meta content="Ctrl blog" property="name">
        <link href="https://www.ctrl.blog/" property="url">
        <span property="logo" typeof="ImageObject">
          <link href="https://www.ctrl.blog/assets/img/publisher-600x60.png" property="url">
          <meta content="600" property="width"> <meta content="60" property="height">
        </span>
      </div>
    <p>
      <span class="byline author vcard" property="author" typeof="Person"><span class="byline-name fn" property="name"><a href="https://www.daniel.priv.no/" property="url">Daniel Aleksandersen</a></span></span>
      <span class="dateline">
          Published: <time class="entry-date dt-published published updated" datetime="2017-12-24T01:23:48+00:00" content="2017-12-24T01:23:48+00:00" property="datePublished" title="Publication time 2017-12-24T01:23:48+00:00">2017-12-24 @099</time>      </span>
      <span class="submitline">
        <a href="https://www.ctrl.blog/about/contact/corrections?pid=70m" title="Submit typos, errors, corrections, updates, … ">Report errors/corrections</a>      </span>
    </p>
<nav class="taglist">
            <p>Topics:</p>
            <ul class="scili andli" property="keywords"><li><a class="tag p-category" href="https://www.ctrl.blog/topic/networking">Networking</a></li>
</ul></nav>
	    </footer>
    </article>
  </main>

    <div class="doc-container">
<aside class="adco adco-recs">
<small>Advertisement</small>
<ins class="adsbygoogle adu-recs adu-fb adu-fr" data-ad-client="ca-pub-1835247814769107" data-ad-format="rectangle" data-ad-slot="4696959042"></ins><script>(adsbygoogle=window.adsbygoogle||[]).push({})</script>
</aside>
    
      <aside class="site-recommendations robots-nocontent">
        <h5>Recommended articles</h5>
        <div class="postlist">
      <article id="article-7136" class="small-post post-7136 post type-post status-publish format-standard has-post-thumbnail hentry category-entry tag-lenovo tag-security" title="Lenovo Companion app doesn’t notify you about security updates to TPM firmware">
        <a href="https://www.ctrl.blog/entry/lenovo-companion-tpm-updates" class="u-url"  tabindex="0">
        <picture>
          <img src="https://www.ctrl.blog/media/lenovo-companion-tpm-updates-75x75.jpeg" srcset="https://www.ctrl.blog/media/lenovo-companion-tpm-updates-75x75.jpeg 75w, https://www.ctrl.blog/media/lenovo-companion-tpm-updates-150x150.jpeg 150w, https://www.ctrl.blog/media/lenovo-companion-tpm-updates-100x100.jpeg 100w, https://www.ctrl.blog/media/lenovo-companion-tpm-updates-120x120.jpeg 120w, https://www.ctrl.blog/media/lenovo-companion-tpm-updates-300x300.jpeg 300w, https://www.ctrl.blog/media/lenovo-companion-tpm-updates-320x320.jpeg 320w, https://www.ctrl.blog/media/lenovo-companion-tpm-updates-600x600.jpeg 600w, https://www.ctrl.blog/media/lenovo-companion-tpm-updates-640x640.jpeg 640w" sizes="(max-width: 75px) 100vw, 75px" />
        </picture>
          <header class="entry-header">
            <h3 class="entry-title p-name" property="headline name"><em>Lenovo Companion</em> app doesn’t notify you about security updates to TPM firmware</h3>
            <div class="entry-metadata">
              <time class="dt-published published" datetime="2017-12-04T15:49:11+00:00"></time>
              <time class="dt-updated updated" datetime="2017-12-22T15:15:23+00:00">2017-12-22T15:15:23+00:00</time>
            </div>
          </header>
        </a>
      </article>
      <article id="article-7123" class="small-post post-7123 post type-post status-publish format-standard has-post-thumbnail hentry category-entry tag-networking" title="TP-Link repeater firmware squanders 715 MB/month">
        <a href="https://www.ctrl.blog/entry/tplink-aggressive-ntp" class="u-url"  tabindex="0">
        <picture>
          <img src="https://www.ctrl.blog/media/tplink-time-75x75.jpeg" srcset="https://www.ctrl.blog/media/tplink-time-75x75.jpeg 75w, https://www.ctrl.blog/media/tplink-time-150x150.jpeg 150w, https://www.ctrl.blog/media/tplink-time-100x100.jpeg 100w, https://www.ctrl.blog/media/tplink-time-120x120.jpeg 120w, https://www.ctrl.blog/media/tplink-time-300x300.jpeg 300w, https://www.ctrl.blog/media/tplink-time-320x320.jpeg 320w, https://www.ctrl.blog/media/tplink-time-600x600.jpeg 600w, https://www.ctrl.blog/media/tplink-time-640x640.jpeg 640w" sizes="(max-width: 75px) 100vw, 75px" />
        </picture>
          <header class="entry-header">
            <h3 class="entry-title p-name" property="headline name">TP-Link repeater firmware squanders 715 MB/month</h3>
            <div class="entry-metadata">
              <time class="dt-published published" datetime="2017-11-24T03:12:23+00:00"></time>
              <time class="dt-updated updated" datetime="2017-12-24T01:28:06+00:00">2017-12-24T01:28:06+00:00</time>
            </div>
          </header>
        </a>
      </article>
      <article id="article-7111" class="small-post post-7111 post type-post status-publish format-standard has-post-thumbnail hentry category-entry tag-networking tag-security" title="TP-Link serves outdated or no firmware at all on 30% of its European websites">
        <a href="https://www.ctrl.blog/entry/tplink-firmware-outdated-downloads" class="u-url"  tabindex="0">
        <picture>
          <img src="https://www.ctrl.blog/media/tplink-packaging-75x75.jpeg" srcset="https://www.ctrl.blog/media/tplink-packaging-75x75.jpeg 75w, https://www.ctrl.blog/media/tplink-packaging-150x150.jpeg 150w, https://www.ctrl.blog/media/tplink-packaging-100x100.jpeg 100w, https://www.ctrl.blog/media/tplink-packaging-120x120.jpeg 120w, https://www.ctrl.blog/media/tplink-packaging-300x300.jpeg 300w, https://www.ctrl.blog/media/tplink-packaging-320x320.jpeg 320w, https://www.ctrl.blog/media/tplink-packaging-600x600.jpeg 600w, https://www.ctrl.blog/media/tplink-packaging-640x640.jpeg 640w" sizes="(max-width: 75px) 100vw, 75px" />
        </picture>
          <header class="entry-header">
            <h3 class="entry-title p-name" property="headline name"><em>TP-Link</em> serves outdated or no firmware at all on 30% of its European websites</h3>
            <div class="entry-metadata">
              <time class="dt-published published" datetime="2017-11-20T17:50:14+00:00"></time>
              <time class="dt-updated updated" datetime="2017-11-20T17:47:32+00:00">2017-11-20T17:47:32+00:00</time>
            </div>
          </header>
        </a>
      </article>
      <article id="article-7112" class="small-post post-7112 post type-post status-publish format-standard has-post-thumbnail hentry category-entry tag-hardware tag-networking" title="What is really the difference between TP-Link RE650 and RE500? Firmware limits.">
        <a href="https://www.ctrl.blog/entry/tplink-re650-vs-re500" class="u-url"  tabindex="0">
        <picture>
          <img src="https://www.ctrl.blog/media/tp-link-ac-range-extenders-re500-re650-75x75.jpeg" srcset="https://www.ctrl.blog/media/tp-link-ac-range-extenders-re500-re650-75x75.jpeg 75w, https://www.ctrl.blog/media/tp-link-ac-range-extenders-re500-re650-150x150.jpeg 150w, https://www.ctrl.blog/media/tp-link-ac-range-extenders-re500-re650-100x100.jpeg 100w, https://www.ctrl.blog/media/tp-link-ac-range-extenders-re500-re650-120x120.jpeg 120w, https://www.ctrl.blog/media/tp-link-ac-range-extenders-re500-re650-300x300.jpeg 300w, https://www.ctrl.blog/media/tp-link-ac-range-extenders-re500-re650-320x320.jpeg 320w, https://www.ctrl.blog/media/tp-link-ac-range-extenders-re500-re650-600x600.jpeg 600w, https://www.ctrl.blog/media/tp-link-ac-range-extenders-re500-re650-640x640.jpeg 640w" sizes="(max-width: 75px) 100vw, 75px" />
        </picture>
          <header class="entry-header">
            <h3 class="entry-title p-name" property="headline name">What is really the difference between TP-Link RE650 and RE500? Firmware limits.</h3>
            <div class="entry-metadata">
              <time class="dt-published published" datetime="2017-11-19T16:12:59+00:00"></time>
              <time class="dt-updated updated" datetime="2017-11-23T03:31:44+00:00">2017-11-23T03:31:44+00:00</time>
            </div>
          </header>
        </a>
      </article>
      <article id="article-6623" class="small-post post-6623 post type-post status-publish format-standard has-post-thumbnail hentry category-entry tag-hardware tag-security" title="Internet connected devices should be sold with best before dates">
        <a href="https://www.ctrl.blog/entry/device-best-before-dates" class="u-url"  tabindex="0">
        <picture>
          <img src="https://www.ctrl.blog/media/stack-of-idevices-75x75.jpeg" srcset="https://www.ctrl.blog/media/stack-of-idevices-75x75.jpeg 75w, https://www.ctrl.blog/media/stack-of-idevices-150x150.jpeg 150w, https://www.ctrl.blog/media/stack-of-idevices-100x100.jpeg 100w, https://www.ctrl.blog/media/stack-of-idevices-120x120.jpeg 120w, https://www.ctrl.blog/media/stack-of-idevices-300x300.jpeg 300w, https://www.ctrl.blog/media/stack-of-idevices-320x320.jpeg 320w, https://www.ctrl.blog/media/stack-of-idevices-600x600.jpeg 600w, https://www.ctrl.blog/media/stack-of-idevices-640x640.jpeg 640w" sizes="(max-width: 75px) 100vw, 75px" />
        </picture>
          <header class="entry-header">
            <h3 class="entry-title p-name" property="headline name">Internet connected devices should be sold with best before dates</h3>
            <div class="entry-metadata">
              <time class="dt-published published" datetime="2017-05-09T12:19:37+00:00"></time>
              <time class="dt-updated updated" datetime="2017-05-22T16:35:23+00:00">2017-05-22T16:35:23+00:00</time>
            </div>
          </header>
        </a>
      </article>
      </aside>
     </div>

    </div>

    <footer id="page-footer">

      <nav class="page-footer-nav">
        <ul class="page-footer-linklist">
          <li><a href="/sitemap" title="Find your way around this website">Sitemap</a></li>
          <li><a href="/tip-jar" title="Help fund niche tech journalism">Funding</a></li>
          <li><a href="/about/colophon" title="About this website">Website colophon</a></li>
          <li><a href="/about/privacy-policy" title="Privacy and cookie policy">Privacy and cookies</a></li>
        </ul>
      </nav>

      <div class="page-footer-signups">
        <section class="page-footer-email">
          <div>
          <h6>Get the newsletter</h6>
          <p><small>Join <strong>2 960 +</strong> readers!</small></p>
          </div>
          <form action="https://software.us12.list-manage.com/subscribe/post?u=68e221724af778767fcd62a0c&amp;id=e498ab3175" method="post" target="_blank">
            <input type="email" name="EMAIL" placeholder="your@email.com" class="emailinput">
            <div aria-hidden="true" style="position:absolute;left:-5000px">
              <input name="group[9809][1]" type="hidden" value="1">
              <input name="b_68e221724af778767fcd62a0c_e498ab3175" tabindex="-1" type="text" value="">
            </div>
            <input class="prominentbutton" name="subscribe" type="submit" value="Subscribe">
            <input type="hidden" name="SIGNUP" value="Blog Footer">
          </form>
          <p>Sign-up now and get Ctrl blog delivered in your inbox weekly!</p>
        </section>

        <section class="page-footer-subscribe">
<ul class="subscriptionlist"><li><a href="https://www.ctrl.blog/feed" target="_blank" title="Add Ctrl blog (Atom) to your feed reader" type="application/atom+xml">Feed</a></li> <li><a href="https://feedly.com/i/subscription/feed/https%3A%2F%2Fwww.ctrl.blog%2Ffeed" rel="nofollow noopener" target="_blank" title="Add Ctrl blog to Feedly">Feedly</a></li> <li><a href="https://twitter.com/CtrlBlog" rel="nofollow noopener" target="_blank" title="Follow @CtrlBlog on Twitter">Twitter</a></li> <li><a href="https://newsblur.com/site/5241507/ctrl-blog" rel="nofollow noopener" target="_blank" title="Add Ctrl blog to Newsblur">Newsblur</a></li> <li><a href="https://www.feedspot.com/infiniterss.php?q=site:https%3A%2F%2Fwww.ctrl.blog%2Ffeed" rel="nofollow noopener" target="_blank" title="Add Ctrl blog to Feedspot">Feedspot</a></li></ul>        </section>

      </div>

      <aside>
        <p><small>Page personalized to your: <a href="https://www.ctrl.blog/about/privacy-policy#privacy-policy-ads">Ad interests</a>.</small></p>
      </aside>

      <p>
        <span class="page-footer-copyright copyright">Copyright © 2006 – 2018 <span property="copyrightHolder creator" typeof="Person"><a href="https://www.daniel.priv.no/" property="sameAs" title="About Daniel"><span property="name">Daniel Aleksandersen</span></a>.</span></span>
        Hosted on both <a href="https://www.ctrl.blog/ac/go/linode" rel="nofollow" title="Linode VPS hosting">Linode</a>
        and <a href="https://www.ctrl.blog/ac/go/vultr" rel="nofollow" title="Vultr VPS hosting">Vultr</a>.
      </p>

<script async src="https://www.ctrl.blog/assets/cjs/37790f56-1510112021.min.js"></script>
      <script>
        (function(){if('sendBeacon' in navigator){function r(){navigator.sendBeacon(
        'https://www.ctrl.blog/visit',7190);}window.addEventListener('unload',r);}})();
        var sc_project=10979187,sc_invisible=1,sc_security="332eac0a",sc_https=1;
        window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
        ga('create','UA-55680813-3',{'siteSpeedSampleRate':5,'storeGac':0});ga('set','anonymizeIp',1);ga('send','pageview');
      </script>
      <script async src="https://www.google-analytics.com/analytics.js"></script>
      <script async src="https://secure.statcounter.com/counter/counter.js"></script>
      <noscript>
        <img src="https://c.statcounter.com/10979187/0/332eac0a/1/" alt="">
      </noscript>
      <script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"https://www.ctrl.blog/","fileFormat":"text/html","name":"Ctrl blog","isAccessibleForFree":"True","hasPart":{"@type":"WebPage","lastReviewed":"2017-12-24T01:23:48+00:00","@id":"https://www.ctrl.blog/entry/ntplink-fixed","url":"https://www.ctrl.blog/entry/ntplink-fixed","hasPart":{"@type":"Article","inLanguage":"en","@id":"urn:uuid:c48ce01d-208e-4724-8113-c41550e9609c","url":"https://www.ctrl.blog/entry/ntplink-fixed","mainEntityOfPage":{"@id":"https://www.ctrl.blog/entry/ntplink-fixed"},"headline":"Latest TP-Link updates resolve NTP data squandering firmware issue","name":"Latest TP-Link updates resolve NTP data squandering firmware issue","description":"TP-Link updates repeaters to rely on ICMP and no longer send excessive NTP/DNS requests every 5 seconds.","dateCreated":"2017-12-24T01:23:48+00:00","datePublished":"2017-12-24T01:23:48+00:00","dateModified":"2017-12-24T01:23:48+00:00","image":[{"@type":"ImageObject","representativeOfPage":"True","height":603,"width":1072,"url":"https://www.ctrl.blog/media/tplink-time-1072x603.jpeg"},{"@type":"ImageObject","representativeOfPage":"True","height":300,"width":300,"url":"https://www.ctrl.blog/media/tplink-time-300x300.jpeg"}],"publisher":{"@id":"https://www.ctrl.blog/"},"author":{"@id":"https://www.daniel.priv.no/"}}},"publisher":{"@type":"Organization","@id":"https://www.ctrl.blog/","url":"https://www.ctrl.blog/","name":"Ctrl blog","legalName":"Aleksandersen","founder":{"@type":"http://schema.org/Person","worksFor":{"@id":"https://www.ctrl.blog/"},"@id":"https://www.daniel.priv.no/","url":"https://www.daniel.priv.no/","name":"Daniel Aleksandersen","givenName":"Daniel","familyName":"Aleksandersen","sameAs":["https://www.daniel.priv.no/","https://twitter.com/Aeyoun"]},"logo":[{"@type":"ImageObject","height":60,"width":600,"url":"https://www.ctrl.blog/assets/img/publisher-600x60.png"},{"@type":"ImageObject","height":310,"width":310,"url":"https://www.ctrl.blog/assets/img/publisher-310x310.png"}],"sameAs":["https://twitter.com/CtrlBlog"]}}</script>
    </footer>
  </body>
</html>
